通达信波段牛人副图指标公式

通达信波段牛人副图指标公式 

DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
AA:=EMA(CLOSE,10);
多头:STICKLINE(DIF>DEA,CLOSE,OPEN,2,0),COLORRED;
STICKLINE(DIF>DEA,HIGH,LOW,2,0),COLORRED;
空头:STICKLINE(DIF<=DEA,CLOSE,OPEN,2,0),COLORGREEN;
STICKLINE(DIF<=DEA,HIGH,LOW,0,0),COLORGREEN;
STICKLINE(DIF<=DEA AND AA>MA(CLOSE,30),CLOSE,OPEN,2,0),COLORYELLOW;
STICKLINE(DIF<=DEA AND AA>MA(CLOSE,30),HIGH,LOW,2,0),COLORYELLOW;
STICKLINE(DIF>DEA AND AA<MA(CLOSE,30),CLOSE,OPEN,2,0),COLOR77AAFF;
STICKLINE(DIF>DEA AND AA<MA(CLOSE,30),HIGH,LOW,2,0),COLOR77AAFF;
A:=(3*C+L+O+H)/6;
多:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+14*REF(A,6)
+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+
REF(A,20))/210;
空:=MA(多,3);
STICKLINE((空< 多),多,空,10,0),COLORFF00FF;
STICKLINE((空 >= 多),多,空,10,0),COLORFFFF00;
RCC:=DYNAINFO(3);
S22:=SMA(C,3,1);
S66:=SMA(C,5,1);
DK:=2*(S22-S66);
KK:=IF(PERIOD=5,0.9,1);
STICKLINE(DK>0,RCC*KK,RCC*KK+DK,0,1),COLORRED;
STICKLINE(DK<0,RCC*KK,RCC*KK+DK,0,1),COLORCYAN;
{关注微信公众号:爱指标源码}
VAR1:=LLV(LOW,21);
VAR2:=HHV(HIGH,21);
AK1:=EMA((((CLOSE – VAR1) / (VAR2 – VAR1)) * 100),5);
AK:=EMA((((CLOSE – VAR1) / (VAR2 – VAR1)) * 50),13);
AB:=CROSS(AK1,AK);
VAR4:=REF(CLOSE,1);
VAR5:=((SMA(MAX((CLOSE – VAR4),0),6,1) / SMA(ABS((CLOSE – VAR4)),6,1)) * 100);
DRAWTEXT(CROSS(80,VAR5),(HIGH * 1.01),’★卖 ‘),COLORFFDDEE;
DRAWTEXT((AB = 1),(LOW * 0.99),’★买’),COLORRED;
买线:=EMA(C,2);
卖线:=EMA(SLOPE(C,21)*20+C,42);
BU:=CROSS(买线,卖线);

© 版权声明
THE END
喜欢就支持一下吧
点赞14赞赏
分享
评论 抢沙发
admin的头像-雨林之家

昵称

取消
昵称表情代码图片